Linux端末からCisco機器にコンソール接続する準備

## root権限なしでminicomを使うためdialoutグループへユーザを追加
sudo usermod -aG dialout $USER
shutdown -r now  # 再起動
id         # 再起動後、グループに追加されているか確認


## シリアルポートが使えるか確認(USBにシリアルケーブルを挿した状態で)
# 通常
ls /dev | grep ttyUSB
 ttyUSB0 が表示されること
        または
# dmesgコマンド使用
sudo echo 'kernel.dmesg_restrict=0'>/etc/sysctl.d/dmesg.conf # dmesg.conf 作成
sudo /etc/sbin/sysctl --system または shutdown -r now # 設定を反映させる
dmesg | grep ttyUSB # 確認
 ttyUSB0 が表示されること

①Linux端末からCisco機器にコンソール接続(cuコマンド使用)

## 環境構築
# cuコマンドのインストール
sudo apt install cu -y

## cuコマンドでCLI接続
cu -s 9600 -l /dev/ttyUSB0
 エンターすると…
R1>  プロンプトが表示される

終了は exit → ×閉じでターミナル終了

②Linux端末からCisco機器にコンソール接続(screen コマンドを使用して作業ログを取りながら)

## 環境準備
# screenのインストール
sudo apt install screen -y

## screen コマンドでCLI接続
screen /dev/ttyUSB0 9600

## キャプチャ開始(~/ ユーザのホームディレクトリ直下に保存される)
Ctrl+A → h 押下 ※ 押下した瞬間から、「hardcopy.0」というファイルに保存がはじまる

# キャプチャ終了
Ctrl+A → k 押下

Linux端末からCisco機器にコンソール接続(minicom使用)

## 環境構築
# minicomのインストール
sudo dnf install minicom -y
sudo apt install minicom -y

# minicomをシリアルポート指定で起動(英語の方が表示が整う)
LANG=C minicom -D /dev/ttyUSB0

Ctrl+A → z 押下
"Serial port setup"を選択
 A - Serial Device : /dev/ttyUSB0 ★
 C - Callin Program :
 D - Callout Program :
 E - Bps/Par/Bits  : 9600 8N1 ★
 F - Hardware Flow Control : No ★
 G - Software Flow Control : No
"Save setup as dfl"を選択 > Configuration Saved
Exit

あとはEnterを押すとCisco機器につながる!


■minicomのキャプチャ機能を使うと、作業しながらログを残せる(~/ ユーザのホームディレクトリ直下に保存される)
# キャプチャを開始する
Ctrl+A → L 押下
 Capture to which file?
 > minicom.cap ← ★リネーム!拡張子は .log か .txt で

# キャプチャを止める
 Ctrl+A → L 押下
    Capture file
 [Close] Pause Exit ← Closeを選ぶとストップできる

Windows端末からCisco機器にコンソール接続
 TeraTermを使おう(COM3)

Cisco ルータ・スイッチの初期化の方法(Cisco IOS操作の基礎)

①startup-configの削除
R1#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm] ←[Enter]キー
[OK]
Erase of nvram: complete

R1#show startup-config
startup-config is not present

②システム再起動
R1#reload
Proceed with reload? [confirm] ←[Enter]キー

デフォルトconfig(C1812J IOS 15.1(3)T4)

Router#show running-config 
Building configuration...

Current configuration : 1202 bytes
!
! No configuration change since last restart
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
crypto pki token default removal timeout 0
!
!
dot11 syslog
ip source-route
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1812-J/K9 sn FHK102653DK
vtp mode transparent
!
!
vlan 10,100,150 
!
vlan 200
 name static-route
!
vlan 999
 name mgmt
!
! 
!
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
end

show tech-support で取得できるコマンド(C1812J)

show version
show running-config
show stacks
show interfaces
show interfaces history
show controllers
show user
show file systems
show file descriptors
show flash: all
dir nvram:
show data-corruption
show memory statistics
show process memory
show process cpu
show process cpu history
show diag
show c1800
show platform
show crypto engine configuration
show crypto engine accelerator statistic
show crypto engine accel ring packet
show crypto engine accel ring pool
show crypto engine accel ring control
show dot11 associations all-client
show ip nbar version
show webvpn session context all
show webvpn stats detail
show webvpn stats context all
show webvpn nbns context all
show webvpn stats cifs
show webvpn stats sock
show crypto key mypubkey rsa
show crypto call admission statistics
show buffers
show buffers usage
show license udi
show license feature
show license file
show license detail
show license status
show license statistics
show inventory
show region
Mempool statistics
Top 100 allocator pc summary
show dmvpn detail
show crypto ipsec client ezvpn
show ip nat statistics
show ip nat translations
show crypto map
show access-list
show crypto isakmp policy
show crypto ipsec transform
show crypto ipsec profile
show crypto isakmp sa
show crypto engine connection active
show crypto ipsec sa

syslogの設定

ログメッセージの出力時刻を分かりやすく表示させるために、以下の設定が推奨
 Cisco(config)#service timestamps debug datetime msec localtime show-timezone
 Cisco(config)#service timestamps log datetime msec localtime show-timezone
 Cisco(config)#service sequence-numbers

 Cisco(config)#clock timezone JST 9
 Cisco(config)#ntp server x.x.x.x

以下の設定は、ログ出力でコマンド入力作業が邪魔されないための設定
 Cisco(config)#line console 0
 Cisco(config-line)#logging synchronous

 Cisco(config)#line vty 0 15
 Cisco(config-line)#logging synchronous

デフォルト値(4096byte)は小さすぎるので必ず変更しましょう。
少し値が大きいのですが、Cisco推奨値は 512000 です。
 Cisco(config)#logging buffered 512000

syslogサーバのIPアドレス 設定例 : 「192.168.10.100」と指定
 Cisco(config)#logging host 192.168.10.100

syslogサーバに送信する際のメッセージの「level」指定 設定例 : 「informational」を指定
 Cisco(config)#logging trap informational

syslogサーバに送信する際のFacility指定 (local0~local7のどの値を使用するかはsyslogサーバの管理者に確認 )
Cisco(config)#logging facility local5

★Catalystスイッチの機種によって、インターフェースのリンクアップ/リンクダウンのログがデフォルトでは
 出力されません。そこで、CatalystスイッチのポートをSYSLOG監視したい場合には、どの機種でも明示的に
 該当インターフェースに対して、以下のlogging event link-statusコマンドを入力することをお勧めします。
 Catalyst(config)#interface range GigabitEthernet 1/1 - 1/48
 Catalyst(config-if)#logging event link-status

DNS

DNS ベースでのホスト名からアドレスへの変換が有効になります。このコマンドはデフォルトで有効になっています。
ip domain lookup

非修飾ホスト名(ドット付き 10 進のドメイン名を持たない名前)を完全修飾ドメイン名に変更するために、
Cisco IOS ソフトウェアによって使用されるデフォルトのドメイン名が定義されます。
非修飾名をドメイン名から区切る最初のピリオドを含めないでください。
ip domain name

(config)# clock timezone JST 9  # タイムゾーンを東京にする HW,SYSクロック両方

=====クロック用の電池が消耗していると保存できない=====
# clock set hh:mm:ss 日(#) 月(EN) 年(#)  # 手動でSYSクロックを設定する

# show clock  # SYSクロックの確認
# clock update-calendar  # SYSクロック から HWクロック に反映させる
  ↓ ↑
# clock read-calendar  # HWクロック から SYSクロック に反映させる
# show calendar  # HWクロックの確認(起動時に読み込むが、電池次第)
==================================================



(config)# hostname R1  # デバイス名を変更
# show interfaces [if名]  # インターフェイスの状態確認

(config)# interface fa 0  # FastEthernet0インターフェイスを指定してif-configモードに移行
(config-if)# no shutdown  # インターフェイス有効化
EtherSwitch routerのVLAN設定

# vlan 10,20  # vlan作成

# conf t
(config)# interface fastEthernet 1/0
(config-if)# switchport mode access  # 1/0をアクセスポートに設定
(config-if)# switchport access vlan 10  # 1/0アクセスポートをvlan10に所属させる
(config-if)# exit

(config)# interface fastEthernet 1/1
(config-if)# switchport mode access  # 1/1をアクセスポートに設定
(config-if)# switchport access vlan 20  # 1/1アクセスポートをvlan20に所属させる
(config-if)# end

# write memory  # 絶対忘れるな★

# conf t
(config)# interface fastEthernet 1/10
(config)# switchport mode trunk  # 1/10をトランクポートに設定
(config)# switchport trunk encapsulation dot1q  # 1/10トランクポートに802.1Q(タグVLAN)を適用する
(config)# end

# write memory  # 絶対忘れるな★

# show interfaces fastEthernet 1/10 trunk  # 確認



GNS3

# リポジトリ追加
sudo add-apt-repository ppa:gns3/ppa

# アップデート&インストール
sudo apt-get update && sudo apt-get install gns3-gui